未加星标

Show outdated composer packages

字体大小 | |
[开发(php) 所属分类 开发(php) | 发布者 店小二03 | 时间 2018 | 作者 红领巾 ] 0人收藏点击收藏

A while back I shared a way to show outdated composer packages . Today, I want to expand on it a little bit. Thanks to this tweet :

#ProTip In your php application add "composer show -mlDo strict" to your build pipeline to let your build fail when there are outdated dependencies. You could for example only run it in feature branches to make sure your team keeps the dependencies up-to-date.

― Walter Tamboer (@waltertamboer) November 5, 2018

I think it’s slightly easy to remember with “ composer show -molD -strict ” (“old”, “mold”). Adding this to the test suite is a great tip too!

For other ways to show the outdated packages (using composer plugins), have a look at this StackOverflow thread .

本文开发(php)相关术语:php代码审计工具 php开发工程师 移动开发者大会 移动互联网开发 web开发工程师 软件开发流程 软件开发工程师

代码区博客精选文章
分页:12
转载请注明
本文标题:Show outdated composer packages
本站链接:https://www.codesec.net/view/611488.html


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 开发(php) | 评论(0) | 阅读(107)