漏洞预警:vBulletin Forum v5 中的两个高危代码执行漏洞尚未修复(含 POC)

HackerNews.cc 12 月 18 日消息 ,安全研究人员上周披露了影响 vBulletin 论坛 CMS 版本 5 的两个代码执行漏洞,直至目前漏洞尚未得到修复。研究人员表示希望供应商能够在黑客开始利用这些安全漏洞攻击 vBulletin 之前尽快发布补丁。


vBulletin 是一个基于phpmysql 数据库服务器的专有互联网论坛软件包, 在互联网上为超过 10 万个网站提供支持,其中包括《 财富》 500 强和 Alexa 排名前 100 万的公司网站和论坛。
漏洞预警:vBulletin Forum v5 中的两个高危代码执行漏洞尚未修复(含 POC)

据悉,这些漏洞是由意大利安全公司 TRUEL IT 的一名专家和一位独立安全研究人员发现的,他们于近期公开了漏洞细节。
第一个漏洞是 vBulletin v5 的远程代码执行漏洞,无 CVE【内含 POC】
攻击者可以将恶意的 PHP 代码包含到服务器上的文件中,例如 access.log,只需在精心构造的请求中使用 [routestring =参数]来包含该文件即可执行恶意代码。
第二个漏洞是 vBulletin v5 的反序列化漏洞( CVE -2017- 17672 )【内含 POC】)
这个漏洞是由于为用户提供的输入上对PHP 的 unserialize() 的不安全使用,导致未经身份验证的攻击者能够删除任意文件,并且在 vBulletin 安装上执行任意代码。
研究人员解释称,vB_Library_Template 的 cacheTemplates() 函数是一个公开的 API,允许从数据库获取一组给定模板的信息以便将它们存储在缓存变量中。 $ temnplateidlist 变量可以直接从用户输入提供给 unserialize(),从而导致出现反序列化问题。
对于这两个漏洞,研究人员发布了概念验证(PoC)代码来解释其严重程度,并且于 11 月 21 日通报给了 vBulletin 开发团队。尽管 vBulletin 开发团队表示会尽快修复这些漏洞,然而直至目前官方仍未发布有效补丁。
消息来源: Security Affairs ,编译:榆榆,校审:FOX
本文由 HackerNews.cc 翻译整理,封面来源于网络。
转载请注明“ 转自 HackerNews.cc ” 并附上原文链接。

本文业界资讯相关术语:网络安全论文 网络安全密钥 网络安全工程师 网络安全技术与应用 网络安全概念股 网络安全知识 网络安全宣传周 网络安全知识竞赛 网络安全事件

tags: 漏洞,vBulletin,代码,POC,v5,PHP,cc,HackerNews,执行,修复,人员,CVE,Forum,unserialize
分页:12
转载请注明
本文标题:漏洞预警:vBulletin Forum v5 中的两个高危代码执行漏洞尚未修复(含 POC)
本站链接:https://www.codesec.net/view/570235.html


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 业界资讯 | 评论(0) | 阅读(258)