未加星标

CyberArk 企业密码保险库现高危远程代码执行漏洞

字体大小 | |
[业界资讯 所属分类 业界资讯 | 发布者 店小二04 | 时间 | 作者 红领巾 ] 0人收藏点击收藏
CyberArk 企业密码保险库现高危远程代码执行漏洞

德国网络安全公司 RedTeam Pentesting GmbH 发现 CyberArk Enterprise Password Vault (企业密码保险库)应用程序中存在严重的远程代码执行漏洞(CVE-2018-9843),可以允许攻击者利用 Web 应用程序的特权对系统进行未经授权的访问

据外媒 4 月 9 日消息,德国网络安全公司 RedTeam Pentesting GmbH 发现 CyberArk Enterprise Password Vault (企业密码保险库)应用程序中存在严重的远程代码执行漏洞(CVE-2018-9843),可以允许攻击者利用 Web 应用程序的特权对系统进行未经授权的访问。

企业密码保险库(EPV)解决方案可帮助组织安全管理其敏感密码,控制各种客户端/服务器和大型机操作系统、交换机、数据库中的特权帐户密码,并使其免受外部攻击者以及恶意内部人员的威胁。

RedTeam Pentesting GmbH 安全公司发现该漏洞驻留在 CyberArk 密码保险库的 Web 访问中,它是由于 Web 服务器不安全地处理反序列化操作的方式造成的,可能允许攻击者在处理反序列化数据的服务器上执行代码。

当用户登录到账户时,CyberArk Enterprise Password Vault 应用程序使用 REST API 向服务器发送一个认证请求,其中包括一个包含以 base64 编码序列化的 . net 对象的授权头。这个序列化的 .net 对象保存了关于用户会话的信息,但是研究人员发现“序列化数据的完整性没有得到保护”。

由于服务器不验证序列化数据的完整性,并且不安全地处理反序列化操作,所以攻击者只能操纵身份验证令牌,将他们的恶意代码注入授权头中,从而获得“在 Web 服务器上未经验证的远程代码执行”。

研究人员强烈建议使用 CyberArk 密码保险库 Web 访问的企业将其软件升级到 9.9.5,9.10 或 10.2 版本。如果无法立即升级软件,那么缓解此漏洞的可能解决方法是禁用对 route / PasswordVault / WebServices 上 API 的任何访问。

本文业界资讯相关术语:网络安全论文 网络安全密钥 网络安全工程师 网络安全技术与应用 网络安全概念股 网络安全知识 网络安全宣传周 网络安全知识竞赛 网络安全事件

tags: CyberArk,Web,攻击者,序列,漏洞,代码,GmbH,Vault,Enterprise,Pentesting,RedTeam,Password
分页:12
转载请注明
本文标题:CyberArk 企业密码保险库现高危远程代码执行漏洞
本站链接:http://www.codesec.net/view/575098.html
分享请点击:


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 业界资讯 | 评论(0) | 阅读(48)