未加星标

PHP 'ext/zip/php_zip.c'释放后重利用远程代码执行漏洞

字体大小 | |
[系统(linux) 所属分类 系统(linux) | 发布者 店小二03 | 时间 20160901 | 作者 红领巾 ] 0人收藏点击收藏
php 'ext/zip/php_zip.c'释放后重利用远程代码执行漏洞

发布日期:2016-06-23
更新日期:2016-09-24
受影响系统:
PHP PHP < 5.5.37
PHP PHP 7.x < 7.0.8
PHP PHP 5.6.x < 5.6.23

描述:

BUGTRAQ ID: 91397
CVE(CAN) ID: CVE-2016-5773
PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。
PHP < 5.5.37, 5.6.x < 5.6.23, 7.x < 7.0.8版本,zip扩展php_zip.c未正确处理反序列化及垃圾收集,远程攻击者通过构造的序列化数据,可执行任意代码或造成拒绝服务。
<*来源:Taoguang Chen
*>
建议:
厂商补丁:
PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://github.com/php/php-src/commit/f6aef68089221c5ea047d4a74224ee3deead99a6?w=1
http://php.net/ChangeLog-5.php
http://php.net/ChangeLog-7.php
https://bugs.php.net/bug.php?id=72434
https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

本文地址:http://www.linuxidc.com/Linux/2016-09/135462.htm


PHP 'ext/zip/php_zip.c'释放后重利用远程代码执行漏洞

本文系统(linux)相关术语:linux系统 鸟哥的linux私房菜 linux命令大全 linux操作系统

主题: PHPHTMLLinuxWeb开发数据
分页:12
转载请注明
本文标题:PHP 'ext/zip/php_zip.c'释放后重利用远程代码执行漏洞
本站链接:http://www.codesec.net/view/483549.html
分享请点击:


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 系统(linux) | 评论(0) | 阅读(21)