未加星标

Systemd vulnerability crashes Linux systems

字体大小 | |
[系统(linux) 所属分类 系统(linux) | 发布者 店小二04 | 时间 2016 | 作者 红领巾 ] 0人收藏点击收藏

Systemd vulnerability crashes Linux systems

A new vulnerability has been discovered that could shut down most linux systems using a command short enough to fit in a tweet.

Linux administrator and founder of the security certificate company SSLMate Andrew Ayer discovered the bug, which has the potential to kill a number of critical commands while making others unstable just by entering the short command: NOTIFY_SOCKET=/run/systemd/notify systemd-notify "".

Ayer described the severity of the bug in an advisory, saying: "All of this can be caused by a command that's short enough to fit in a Tweet. The bug is serious, as it allows any local user to trivially perform a denial-of-service attack against a critical system component".

The reason he has decided to disclose the bug publicly was to bring further attention to problems with a widely used component in Linux called systemd that Ayer believes is "defective by design".

However, others believe disclosing such a bug without first contacting systemd's developers is irresponsible. Ayer was critical of systemd for being overly complex and made the argument that Linux developers have "fallen behind other operating systems in writing secure and robust software".

Most major Linux distributions have adopted systemd and use it as their default initialization system which has stirred up controversy with a number of people in the Linux community. Critics have taken issue with the fact that distributions often have to add it to their version of the Linux operating system as other popular software depends upon it.

Ayer took further issue with the way in which systemd compromises security practices, saying: "Systemd is dangerous not only because it is introducing hundreds of thousands of lines of complex C code without any regard to longstanding security practices like privilege separation or fail-safe design, but because it is setting itself up to be irreplaceable".

As of this time, a patch for the issue Ayer discovered has been released on the GitHub code repository that appears to work on some systems through the use of a while true loop.

Published under license from ITProPortal.com, a Future plc Publication. All rights reserved.

Photo Credit: Spectral-Design / Shutterstock

本文系统(linux)相关术语:linux系统 鸟哥的linux私房菜 linux命令大全 linux操作系统

主题: LinuxGitGitHubTI
分页:12
转载请注明
本文标题:Systemd vulnerability crashes Linux systems
本站链接:http://www.codesec.net/view/482875.html
分享请点击:


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 系统(linux) | 评论(0) | 阅读(21)