linux kernel the __sys_recvmmsg函数释放后重利用漏洞(CVE-2016-7117)

发布日期:2016-10-05

更新日期:2016-10-12

受影响系统:

Linux kernel < 4.5.2

描述:

CVE(CAN) ID: CVE-2016-7117

Linux Kernel是Linux操作系统的内核。

Linux kernel < 4.5.2 版本,net/socket.c/the __sys_recvmmsg函数存在释放后重利用漏洞。可使远程攻击者执行任意代码。

<*来源:Andrej Nemec

*>

建议:

厂商补丁:

Linux

-----

目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=34b88a68f26a75e4fded796f1a49c40f82234b7d

https://bugzilla.redhat.com/show_bug.cgi?id=1382268

http://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.5.2

https://github.com/torvalds/linux/commit/34b88a68f26a75e4fded796f1a49c40f82234b7d

http://source.android.com/security/bulletin/2016-10-01.html

https://bugzilla.novell.com/show_bug.cgi?id=1003077

https://people.canonical.com/~ubuntu-security/cve/2016/CVE-2016-7117.html

Linux Kernel 4.2.2 编译安装教程 http://www.codesec.net/Linux/2015-10/123714.htm

Ubuntu 15.10 将使用 Linux Kernel 4.2 内核 http://www.codesec.net/Linux/2015-09/122826.htm

怎样在CentOS 7 上安装 Kernel 4.0.2 http://www.codesec.net/Linux/2015-05/117574.htm

怎样在 CentOS 7 系统上安装Linux Kernel 4.0 http://www.codesec.net/Linux/2015-04/116461.htm

如何在Ubuntu/CentOS上安装Linux内核4.0 http://www.codesec.net/Linux/2015-04/116565.htm

如何在Ubuntu 13.10上安装Linux内核 3.12 http://www.codesec.net/Linux/2013-11/92930.htm

如何在Ubuntu 14.10,Ubuntu 14.04及其衍生版本安装 3.16.7 CKT2内核 http://www.codesec.net/Linux/2014-12/110189.htm

Linux Kernel 的详细介绍 : 请点这里

Linux Kernel 的下载地址 : 请点这里

本文地址 : http://www.codesec.net/Linux/2016-10/135959.htm

本文系统(linux)相关术语:linux系统 鸟哥的linux私房菜 linux命令大全 linux操作系统

主题: LinuxUbuntuLinux内核
分页:12
转载请注明
本文标题:Linux kernel the __sys_recvmmsg函数释放后重利用漏洞(CVE-2016-7117)
本站链接:http://www.codesec.net/view/481832.html
分享请点击:


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 系统(linux) | 评论(0) | 阅读(105)