Today, October 11, 2016, Canonical published several security advisories to inform Ubuntu users about new linux kernel updates for their supported operating systems.

Four new kernel vulnerabilities are affecting Ubuntu 16.04 LTS (Xenial Xerus) and Ubuntu 14.04 LTS (Trusty Tahr) or later versions, and three the Ubuntu 12.04 LTS (Precise Pangolin) series of operating systems. They are also affecting the Ubuntu 16.04 LTS for Raspberry Pi 2 kernel.

The first security flaw is an unbounded recursion in Linux kernel's VLAN and TEB Generic Receive Offload (GRO) processing implementations, which could have allowed a remote attacker to crash the system through a denial of service or cause a stack corruption. It was discovered by Vladimír Bene and affects Ubuntu 16.04 and 14.04.

The second vulnerability is a use-after-free condition in Linux kernel's TCP retransmit queue handling code, which could have allowed a local attacker to crash the system through a denial of service or execute malicious code. The issue was discovered by Marco Grassi and affects Ubuntu 16.04 LTS, Ubuntu 14.04 LTS, and Ubuntu 12.04 LTS.

The third kernel issue is a race condition in Linux kernel's s390 SCLP console driver, which could have allowed a local attacker to retrieve delicate information from kernel memory. This vulnerability was discovered by Pengfei Wang and affects only users of the Ubuntu 16.04 LTS operating system, excluding the Raspberry Pi 2 kernel.

The fourth and fifth security flaws are race conditions discovered by Pengfei Wang in Linux kernel's audit subsystem and Adaptec AAC RAID controller driver respectively, which could have allowed a local attacker to crash the system via a denial of service, disrupt the system-call auditing, or the corrupt audit logs.

Users are urged to update their systems immediately

Canonical urges users of the Ubuntu operating systems mentioned above to update immediately. The new kernel versions are linux-image-4.4.0-42 (4.4.0-42.62) for Ubuntu 16.04 LTS, linux-image-3.13.0-98 (3.13.0-98.145) for Ubuntu 14.04 LTS, and linux-image-3.2.0-111 (3.2.0-111.153) for Ubuntu 12.04 LTS.

Additionally, Ubuntu 16.04 LTS for Raspberry Pi 2 gets linux-image-4.4.0-1027-raspi2 (4.4.0-1027.33) , Ubuntu 12.04 LTS Trusty HWE receives linux-image-3.13.0-98 (3.13.0-98.145~precise1) , and Ubuntu 14.04 LTS Xenial HWE gets linux-image-4.4.0-42 (4.4.0-42.62~14.04.1) .

To update your system, use the Software Updater or Ubuntu Software applications, as well as Synaptic Package Manger or the APT command-line package manager. More details are provided by Canonical at https://wiki.ubuntu.com/Security/Upgrades . Don't forget to reboot your system after a kernel update!

本文系统(linux)相关术语:linux系统 鸟哥的linux私房菜 linux命令大全 linux操作系统

主题: UbuntuLinuxRaspberry PiXen
分页:12
转载请注明
本文标题:Canonical Patches New Linux Kernel Vulnerabilities in All Supported Ubuntu OSes
本站链接:http://www.codesec.net/view/481429.html
分享请点击:


1.凡CodeSecTeam转载的文章,均出自其它媒体或其他官网介绍,目的在于传递更多的信息,并不代表本站赞同其观点和其真实性负责;
2.转载的文章仅代表原创作者观点,与本站无关。其原创性以及文中陈述文字和内容未经本站证实,本站对该文以及其中全部或者部分内容、文字的真实性、完整性、及时性,不作出任何保证或承若;
3.如本站转载稿涉及版权等问题,请作者及时联系本站,我们会及时处理。
登录后可拥有收藏文章、关注作者等权限...
技术大类 技术大类 | 系统(linux) | 评论(0) | 阅读(27)